Написать программу , которая подсчитывает произведение натуральных чисел от 1 до n .

ryzhovaelena1 ryzhovaelena1    3   17.09.2019 00:40    9

Ответы
Ниа15082006 Ниа15082006  07.10.2020 20:50
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
write(range(1,ReadInteger('n=')).Aggregate(Real(1),(x,y)->x*y));
end.
ПОКАЗАТЬ ОТВЕТЫ
Aminka555112 Aminka555112  07.10.2020 20:50
Var
  i, n: integer;
  P: real;
Begin
  Write('n = ');
  ReadLn(n);
  P := 1;
  For i := 1 to N do
    P := P * i;
  WriteLn('P = ',P);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика