Это ! на вход программы произвольные алфавитно-цифровые символы. ввод этих символов заканчивается точкой. требуется написать программу, которая будет печатать последовательность строчных букв ('a' 'b' 'z') из входной последовательности и частот их повторения. печать должна происходить в алфавитном порядке. например, пусть на вход следующие символы: fhb5kbfыshfm. в этом случае программа должна вывести b2 f3 h2 kl ml s1

папенко папенко    2   26.07.2019 00:30    12

Ответы
kristinarepina kristinarepina  24.09.2020 18:29
Var s:string;
a:array['a'..'z'] of integer;
i:integer; c:char;
begin
writeln('Введите строку:');
readln(s);
for c:='a' to 'z' do a[c]:=0;
for i:=1 to length(s) do
 if (s[i]>='a')and(s[i]<='z') then a[s[i]]:=a[s[i]]+1;
for c:='a' to 'z' do
 if a[c]>0 then writeln(c,' ',a[c]);
end.

Программа:
Введите строку:
fhb5kbfыshfm.
b 2
f 3
h 2
k 1
m 1
s 1
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика