Домашнее задание 1. Напишите программу, которая находит сумму и произведение двух целых чисел, введённых с клавиатуры.
Например, при вводе чисел 4 и 7 мы должны получить ответ
4+7=11
4*7=28

2. Ввести число, обозначающее количество секунд. Вывести то же са-мое время в минутах и секундах.
Пример:
Введите число секунд: 175
2 мин. 55 с

maхimus maхimus    3   30.01.2022 06:44    1

Ответы
p1pal1 p1pal1  30.01.2022 06:50

Если нужен паскаль:

1.

var

 a,b:integer;

begin

 readln(a,b);

 writeln(a,'+',b,'=',a+b);

 writeln(a,'*',b,'=',a*b);

end.

2.

var

 n,c,m,h:integer;

begin

 readln(n);

 m:=n div 60;

 c:=n mod 60;

 if m>=60 then

   begin

     h:=m div 60;

     m:=m mod 60;

     if m<>0 then

       if c<>0 then

         write(h,'ч ',m,'мин ',c,'с')

       else

         write(h,'ч ',m,'мин ')

     else

       if c<>0 then

         write(h,'ч ',c,'с')

       else

         write(h,'ч');

   end

     else

       if m<>0 then

         if c<>0 then

           write(m,'мин ',c,'с')

         else

           write(m,'мин ')

       else

         write(c,'с');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика