Добрые люди ! решить данную на паскале напишите программу, чтобы создавала палиндром любой строки. палиндром - исходная строка + обратное представление строки (на входе – abc; на выходе abccba)

taibat3 taibat3    1   16.09.2019 14:30    0

Ответы
айка395 айка395  07.10.2020 19:54
1. Современное решение

// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString;
  s:=s+s.Inverse;
  s.Println
end.

Пример
abc
abccba

2. Так все еще учат в большинстве (но уже не во всех!) школ

program Palindrom;

var
  s:string;
  i,n:integer;

begin
  Readln(s);
  for i:=Length(s) downto 1 do s:=s+s[i];
  Writeln(s)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика