Для каждой составить программу в pascal, выводящую значение true, если указанное высказывание является истинным, и false - в противном случае (использовать условный оператор нельзя). 10. в заданном натуральном трехзначном числе n имеется чётная цифра. 11. сумма каких-либо двух цифр заданного трёхзначного натурального числа n равна третьей цифре. 12. сумма цифр заданного четырёхзначного числа n превосходит произведение цифр этого же числа на 1. 13. сумма двух последних цифр заданного трёхзначного числа n меньше заданного k, а первая цифра больше

25182830 25182830    3   13.06.2019 06:20    5

Ответы
cernyshova cernyshova  10.07.2020 12:16
// 10.
var
  n: integer;
begin
  read(n);
  Write((n div 100 mod 2 = 0) or (n mod 10 mod 2 = 0) or (n mod 100 div 10 mod 2 = 0));
end.

// 11.
var
  n: integer;
  a,b,c:integer;
begin
  read(n);
  a:=n div 100; b:=n mod 100 div 10; c:=n mod 10;
  Write((a+b=c)or(a+c=b)or(c+b=a));
end.

// 12.
var
  n: integer;
  a,b,c,d:integer;
begin
  read(n);
  a:=n div 1000; b:=n mod 1000 div 10 div 10; c:=n mod 100 div 10; d:=n mod 10;
  Write(a+b+c+d-1=a*b*c*d);
end.

// 13.
var
  n,k: integer;
  a,b,c:integer;
begin
  Write('n,k= '); read(n,k);
  a:=n div 100; b:=n mod 100 div 10; c:=n mod 10;
  Write((b+c<k)and(a>5));
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика