Decimal to Binary На вход программе подается натуральное число, записанное в десятичной системе счисления. Напишите программу, которая переводит данное число в двоичную систему счисления. Формат входных данных На вход программе подается одно натуральное число. Формат выходных данных Программа должна вывести число записанное в двоичной системе счисления. Тестовые данные green_circle Sample Input 1: 5 Sample Output 1: 101 Sample Input 2: 128 Sample Output 2: 10000000 Питон

Ампорик Ампорик    1   18.10.2021 13:47    10

Ответы
EnemySSS EnemySSS  18.10.2021 13:50

Программа:

n = int(input('Введите натуральное число (в 10-й СС): '))

k = ''

while n > 0:

   i = str(n % 2)

   n = int(n / 2)

   k = i + k

print(k)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика