C++ треугольник паскаля
Треугольник Паскаля строится следующим образом. Первая строка состоит из одного числа, равного единице. Каждая следующая содержит на одно число больше, чем предыдущая. Первое и последнее из этих чисел равны 1, а все остальные вычисляются как сумма числа, стоящего в предыдущей строке над ним и числа, стоящего в предыдущей же строке слева от него.

Входные данные.
Записано одно число N (0 ≤ N ≤ 30).

Выходные данные.
Вывести N строк треугольника Паскаля.

Примечание. Все числа в треугольнике Паскаля при указанных ограничениях входят в integer.

Пример входных данных
8

Пример выходных данных понять не могу

SuperZadrot200 SuperZadrot200    1   01.04.2020 18:58    23

Ответы
svetlanaariann svetlanaariann  12.10.2020 12:06

#include <iostream>

using namespace std;

                   

double Cnk(int N,int K){

return ( (N<K) ? 0 : ((K==0) ? 1 : ((N-K+1) / double(K) * Cnk(N,K-1))) );

}

                 

int main(){

   int n;

   cin>>n;

for (int j = 0; j <= n; j++) {

 for (int i=0; i <=j ; i++)

  cout<<Cnk(j,i)<<" ";

 cout<<"\n";

}

   std::cin.get();

   std::cin.get();

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика