Даны две дроби a b и c d

напишите программу, которая находит целую часть их суммы.

входные данные в первой строке указаны через пробел целые числа a, b, c и d

(1 6 a, b, c, d 6 100).

результат выведите целую часть суммы a

b + c=d
выразить в программу паскаль

sallyllyi sallyllyi    1   12.10.2019 11:02    3

Ответы
ангелина123456543216 ангелина123456543216  10.10.2020 06:08

Для начала решим это математически:

Пусть \frac{a}{b} и \frac{c}{d} - данные дроби.

Их сумма будет:

\frac{a}{b}+\frac{c}{d}=\frac{a*d+b*c}{b*d}

И нужно найти целую часть от деления (a*d+b*c) на (b*d).

Теперь составляем программу:

var a,b,c,d: integer;

begin

readln(a,b,c,d);

write(abs(a*d+b*c) div abs(b*d));

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика