Даны два натуральных числа m и n (m≤n). Напишите программу, которая выводит все числа от m до n включительно удовлетворяющие хотя бы одному из

условий:

● число кратно 12;

● число оканчивается на 5;

● число кратно 2 и 6 одновременно

Сделать все на Python

katyaarbato katyaarbato    3   31.01.2022 20:25    10

Ответы
Нezнaйка Нezнaйка  31.01.2022 20:30

m=int(input())

n=int(input())

for i in range(m,n+1):

   if i%12==0 or i%10==5 or (i%2==0 and i%6==0):

       print(i)

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Бацио Бацио  31.01.2022 20:30

m = int(input("m = "))

n = int(input("n = "))

num = range(m,n+1)

for n in num:

   if n % 12 == 0:

       print(n)

   if int(str(n)[-1]) == 5:

       print(n)

   if n % 2 == 0 and n % 2 == 0:

       print(n)

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика