Дано слово длиной не менее 8 символов написать программу которая переносит 1 букву в конец слова

Voprosik4695 Voprosik4695    2   22.05.2019 11:50    3

Ответы
linnik4Platon linnik4Platon  17.06.2020 21:14

uses crt;
var
  s:string;p:char; i:integer;
begin
  write('Введи слово, в котором не менее 8 букв:  '); readln(s);
  if length(s)<8 then write('Вы ввели слишком короткое слово.')
  else
  begin
    p:=s[1];
    for i:=1 to length(s) do

      s[i]:=s[i+1];
      s[i]:=p;
      write(s);
  end;
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика