Дано шестизначное число. написать программу, которая определяетявляется ли оно счастливым (сумма первых трех цифр равна сумме последних трех). если число счастливое вывести на экран слово happy, в противном случае вывести на экран слово no (никакие поясняющие записи в программе делать не нужно! библиотеку conio.h и команду getch() перед отправкой файла необходимо удалить! ) в c++

Алина1116577 Алина1116577    1   24.08.2019 00:10    13

Ответы
kramina031 kramina031  05.10.2020 15:33
#include <iostream>
using namespace std;

int main()
{
    int A;
    int B,C;
    cin >> A;
    B=0;
    for (int i = 1; i<=3; i++)
    {
        B+=A%10;
        A = A / 10;
    }
    C=0;
    for (int i = 1; i<=3; i++)
    {
        C+=A%10;
        A = A / 10;
    }
    if (B==C) cout << "HAPPY" << endl;
    else cout << "NO" << endl;
    return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
лалвллв лалвллв  05.10.2020 15:33
#include <iostream>
using namespace std;

int main() {
int n;
cout << "n = ";
cin >> n;
if (
( (int) n / 100000 ) +
( (int) (n % 100000) / 10000 ) +
( (int) (n % 10000) / 1000 )
==
( (int) (n % 1000) / 100 ) +
( (int) (n % 100) / 10 ) +
( (int) n % 10 )
) {
cout << "HAPPY" << endl;
}
else {
cout << "NO" << endl;
}
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика