Дано натуральное 4-х значное число. напишите программу, которая считает и выводит ответ на вопрос получает новое число, содержащие цифры первоначального числа, записанные в обратном порядке и вывести это число на экран и сумму изначально заданного числа и и полученного числа.
program t;
var n, n2, s: integer;
begin
readln(n);
n2:=(n mod 10)*1000+(n div 10 mod 10)*100+(n div 100 mod 10)*10+(n div 1000);
s:=n+n2;
writeln(n2);
writeln(s)
end.