Дано n (n больше 0) натуральных чисел. написать программу, определяющую наибольшее среди них. число n вводится перед всеми остальными числами

us05042007 us05042007    1   28.07.2019 13:50    2

Ответы
Valentinka079 Valentinka079  25.09.2020 20:16
 var n,i,max:integer; 
     a:array[1..10000] of integer;
begin
randomize;
 writeln('Введите кол.натур. чисел: ');
 read(n); 
 for i:=1 to n do     begin   
a[i]:= random(n*n);
    write(a[i],' ');
      //read(a[i]); //Если нужен ввод с клавиатуры
    end;
    writeln;
    max:=a[1];
  for i:=1 to n do     begin     
if a[i]>= max then       
  begin 
         max:=a[i];
  end;
end;

  writeln('Наибольшее число:', max);

end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика