Дана последовательность n элементов. написать программу которая прдсчитает сумму элементов этой последовательности.

vadimfarxudinov vadimfarxudinov    2   19.08.2019 08:00    6

Ответы
mihatyt100 mihatyt100  20.08.2020 11:36
Const m = 100;
var i,n,s: integer;
    a: array[1..m] of integer;
begin
  write('размер массива: ');  readln(n);
  randomize;
  s:=0; 
  writeln('исходный массив: ');
  for i:=1 to n do
  begin
    a[i]:=random(-50,50);
    write(a[i],' ');
    s:=s+a[i]; 
  end;
  writeln;
  writeln('сумма элементов: ',s);
end.


размер массива: 15
исходный массив: 
20 -20 8 -8 25 42 1 38 -31 17 30 2 -6 -43 35 
сумма элементов: 110
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика