Дана площадь квадрата. составьте программу для вычисления его стороны и периметра. программу хорошую и понятную составить( в паскале), все-таки не мало

Ghostremel Ghostremel    1   22.07.2019 15:40    2

Ответы
Maximismailov281 Maximismailov281  13.08.2020 21:02
var
  s, a, p: real;
begin
  write('Введите площадь квадрата: ');
  read(s);
  a := sqrt(s); //Сторона
  p := a * 4; //Периметр
  writeln('Сторона квадрата = ', a : 0 : 2);
  writeln('Периметр квадрата = ', p : 0 : 2);
end.
ПОКАЗАТЬ ОТВЕТЫ
shabrikovayana shabrikovayana  13.08.2020 21:02
Var
  s:real; //Могут быть и не целые числа
Begin
  Write('Введите площадь квадрата ');
  Readln(s);
  Write('Сторона квадрата равна ',sqrt(s),', а периметр ',sqrt(s)*4); // sqrt - это квадратный корень (тобиш длина квадрата) а sqrt(s)*4 - это сторона квадрата умноженная на 4 стороны тобиш периметр 
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика