Дан прямоугольный массив целых положительных чисел 10 х 20. опишите на языке или на одном из языков программирования алгоритм поиска строки с наименьшей суммой элементов. вывести на печать номер строки и сумму ее элементов.
предполагается, что такая строка единственна. составить программу в

dimas1410 dimas1410    2   01.03.2019 15:10    6

Ответы
tanya200525 tanya200525  23.05.2020 18:20

program xxx;

  var i, j, k, min : integer;

        a:array[1..10, 1..20] of integer;

        b:array[1..10] of integer;

begin

   for i:=1 to 10 do

     for j:=1 to 20 do

        readln(a[i,j]);

   for i:=1 to 10 do

    begin

     b[i]:=0;

     for j:=1 to 20 do

       b[i]:=b[i]+a[i,j];

    end;

   min:=b[1]; k:=1;

   for i:=2 to 10 do

     if b[i]<min then begin max:=b[i]; k:=i end;

   writeln('наименьшая сумма элементов =', min);

   writeln('она находится в строке -', k);

   readln

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика