tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан одномерный массив n целых
Дан одномерный массив n целых чисел. заменить в данной последовательности чётные элементы на их удвоение.
topciknazaraakinceva
1 19.07.2019 19:10
4
Ответы
сема10
03.10.2020 08:09
Const n = 10;
Var m : array[1..n] of Integer;
i : Integer;
Begin
Randomize;
For i:=1 to n do
Begin
m[i]:=Random(50);
Write(m[i]:3);
end;
Writeln;
For i:=1 to n do
Begin
If not Odd(m[i]) then m[i]:=m[i]*2;
Write(m[i]:3);
end;
Writeln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
nika06102007
19.05.2019 03:10
Кто живёт в орске ..нам училка задала выбрать один магазин и рассказать что там я выбрала магазин ценопад на мире что там дальше я сама сделаю...
artemantonuc
19.05.2019 03:10
Составить программу для вычисления значения функции y для заданного значения x у= если x -3 то y= √1 - x² если 1,51,5, то y=tg x составить словесное описание алгоритма, составить...
тикон3
19.05.2019 03:10
Дан текст в виде строки. слова в строке разделены несколькими пробелами. требуется удалить лишние пробелы, оставив только по одному между словами....
iliabalagansky
19.05.2019 03:00
Программа 15. определить, поместится ли квадрат площади p в круг площади s или круг поместится в квадрат, или они не поместятся друг в друга (центры круга и квадрата находятся...
PoMOgiTe212lk
19.05.2019 03:00
Программа 12. написать программу, которая бы по номеру дня недели (целому числу от 1 до 7) выдавала бы количество уроков в вашей группе (или сообщение «выходной»). программа...
масяня114
19.05.2019 03:00
Даны натуральное число n, символы . , группы символов, разделённые пробелами (одним или несколькими) и не содержащие пробелов внутри себя , будем называть словами. подсчитать...
TanushaGuda
19.05.2019 03:00
Программа должна обладать следующими свойствами: 1). последовательность команд, реализуемость заданного алгоритма 2). системность, дискретность, понятность 3). дискретность,...
Лиза45111
19.05.2019 03:00
Значения двух массивов a[1..10] и b[1..10] с следующего фрагмента программы: for i: =1 to 10 do a[i]: =10-i; for i: =1 to 10 do b[i]: =a[5] – a[i] сколько элементов массива...
sdgsdgsdgsdgsdg228
19.05.2019 03:00
Придумайте кодированияцветов 32 цветной палитры...
11516118
19.05.2019 02:50
Там задали по информатике! ! дружат три мальчика: слава, витя и женя. одному нравится играть в футбол, другой любит играть на скрипке, любимое занятие третьего - компьютерные...
Популярные вопросы
План пересказ( тополек в красной косынке.)сделайте пунктов).1.2.310....
2
Дан четырехугольник ABCD и точка О. Построить фигуру F, на которою отображается...
3
Ворот используют для подъема воды в колодце. определите выигрыш в силе,...
1
1. Укажіть складне речення (розділові знаки пропущені): а) Сонце піднімається...
3
Знайдіть добуток коренів рівняння x2+3x-4=0...
1
Тәуелсіз сөзін буынға бөлу ...
2
Чтобы создать совершенно новый документ надо нажать...
1
Каковы последствия колониального раздела Африки. Укажите 2 верных ответа...
1
Выберите видообразование Бабочек с темной окраскойА)АллонатрическоеВ)ГенетическоеС)БиохимическиеD)Вегативное...
3
Среднее арифметическое двух чисел равно 18. Найдите эти числа, если одно...
3
Var m : array[1..n] of Integer;
i : Integer;
Begin
Randomize;
For i:=1 to n do
Begin
m[i]:=Random(50);
Write(m[i]:3);
end;
Writeln;
For i:=1 to n do
Begin
If not Odd(m[i]) then m[i]:=m[i]*2;
Write(m[i]:3);
end;
Writeln;
end.