Программа 12. написать программу, которая бы по номеру дня недели (целому числу от 1 до 7) выдавала бы количество уроков в вашей группе (или сообщение «выходной»). программа 13. пользователь вводит действительное число. требуется определить: 1. положительное это число или отрицательное; 2. целое это число или нецелое; 3. четное это число или нечетное; выбор варианта определяется пользователем.

PoMOgiTe212lk PoMOgiTe212lk    1   19.05.2019 03:00    5

Ответы
Волщебница Волщебница  12.06.2020 08:16
12) var A: array[1..7] of integer;
k: integer;
begin
randomize;
for k := 1 to 7 do
A[k] := random(5);
write("vvedite den' nedeli: ");
readln(k);
if (k < 1 or k > 7) writeln("error");
else if ( A[k] <> 0) then writeln("segodnya urokov: ", A[k]);
else write("vyhodnoy");
end.

13) var k: real;
begin
write("vvedite chislo: ");
readln(k);
if (k > 0) then write("polozhitel'noe, ");
else if (k < 0) then write("otricatel'noe, ");
else write("nol', ");
if (k mod 1 <> 0) then write("neceloe, ");
else write("celoe, ");
if (k mod 2 <> 0) then writeln("nechetnoe");
else writeln("chetnoe");
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика