Дан одномерный массив A[10]. Элементы массива – это вещественные случайные
числа большие -60 и меньшие 100. Написать программу, которая будет находить
количество элементов массива, кратных числу 8 и больших 10.

Vens12 Vens12    1   10.04.2020 14:58    2

Ответы
tanyaNat82 tanyaNat82  30.07.2020 13:13

( Решение на Pascal )

Не совсем ясно, каким образом составители задачи планировали найти среди случайных вещественных 10 чисел в диапазоне от -60 до 100 числа, кратные 8.

Но ради Бога:

var A: array [1..10] of real;

var i,s: integer;

begin

s:=0;

randomize();

for i:=1 to 10 do

 begin

 A[i]:=random()*160-60;

 write(A[i]:3:5,' ');

 if (A[i]>10) and (A[i]-trunc(A[i])=0)  

 and (trunc(A[i]) mod 8 =0) then

 s:=s+1;

 end;

writeln();

writeln('Количество элементов массива,',

'кратных числу 8 и больших 10: ',s);

end.


Дан одномерный массив A[10]. Элементы массива – это вещественные случайные числа большие -60 и меньш
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика