Дан массив, содержащий 2016 целых чисел. необходимо найти и вывести сумму тех элементов этого массива, чётность которых совпадает с чётностью максимального элемента. например, в массиве из 6 элементов, равных соответственно 2, 3, 1, 5, 6, 4, максимальный элемент чётный (6), значит, ответом будет сумма чётных элементов этого массива 2 + 6 + 4 = 12. написать программу на паскале

natalavorona358 natalavorona358    2   23.07.2019 14:00    14

Ответы
vayler50p014sh vayler50p014sh  15.09.2020 22:51
Var a,max,sum:integer;
    arr:array [0..2015] of integer;
    begin
randomize;
max:=-500;
sum:=0;
for a:=0 to 2015 do begin
arr[a]:=random(1001)-500;
if max<arr[a] then max:=arr[a];
end;
write('максимальный элемент массива ==> ',max);
writeln();

if max mod 2 = 1 then begin
for a:=0 to 2015 do begin
if arr[a] mod 2 =1 then sum:=sum+arr[a];
end;
writeln('сумма чисел одинаковой чётности числу ',max,' = ',sum);
end;

sum:=0;
if max mod 2 = 0 then begin
for a:=0 to 2015 do begin
if arr[a] mod 2 =0 then sum:=sum+arr[a];
end;
writeln('сумма чисел одинаковой чётности числу ',max,' = ',sum);
end;

end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика