Дан массив из 20 действительных чисел. напишите программу, которая складывает отдельно все положительные элементы этого массива, а отдельно отрицательные элементы и выдает на экран полученные результаты. желательно подробную программу, буду всем )

ХозяинНосочков ХозяинНосочков    1   04.07.2019 03:00    3

Ответы
shesasha66 shesasha66  27.07.2020 22:17
Var A:array[1..20]of real;
B,C:real;
i:byte;
Begin
WriteLn('Введи элементы массива через пробел');
For i:= 1 to 20 do
 Read(A[i]);
For i:= 1 to 20 do
 if A[i]>0 then B:=B+A[i]
 else C:=C+A[i];
WriteLn('Сумма положительных элементов = ',B);
WriteLn('Сумма отрицательных = ',C)
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика