tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан массив действительных чисел
Дан массив действительных чисел размерностью n. подсчитать, сколько в нем отрицательных, положительных и нулевых элементов c++
REDUCE007
1 01.10.2019 05:50
5
Ответы
kasym2
09.10.2020 07:09
#include <iostream>#include <array>#include <algorithm>#include <functional>template <std::size_t size>int count(std::array<int, size> const& arr_, std::function<bool(int)> const& f){ return std::count_if(arr_.begin(), arr_.end(), f);}int main(){ std::array<int, 5> arr = { -2, 0, 5, 0, -1 }; int positive = count(arr, [](int a){ return a > 0; }); int negative = count(arr, [](int a){ return a < 0; }); int zero = count(arr, [](int a){ return a == 0; }); std::cout << positive << " " << negative << " " << zero;}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
aktczzzzz
11.01.2020 17:55
Все 5-буквенные слова, составленные из букв о, п, р, т, записаны в алфавитном порядке и пронумерованы. вот начало списка: 1. 2. 3. 4. 5. какие слова находятся в...
TMTEMI
11.01.2020 18:06
Команда удаления папки c: \ windows del c: \ windows \ *.* deltree c: \ windows \ *.* deltree c: \ window s del c: \ windows p.s. предполагаю что либо 1 либо 4....
Feraaa2108
11.01.2020 18:11
Локальная сеть как основной элемент поисковой системы. 100...
ellaandharley30
11.01.2020 18:18
Какое число является лишним и почему: 1 2 3 5 6 7. можно не быстро...
DashkaPypsik
14.09.2019 05:30
Лабораторная работа по информатике. v1 литров воды нагревается на электроплите от температуры t0 до температуры t1, а v2 литров- до температуры t2. сколько будет...
ryckovan3
14.09.2019 05:30
Вычислить f (x)=1/x, x не равно 0, при x= -10,- с использованием оператора for...
дина372
14.09.2019 05:30
Запишите условие поиска файлов, в имени которых встречается «z»...
kirillsolodov20
28.08.2019 22:40
Какой из этих адресов не может существовать: 109.256.33.18 или 111.223.44.1? поясните....
alskdjfhg123a
08.09.2019 04:20
Какое из чисел следует за числом 127 8 в восьмеричной системе исчисления? какое из чисел следует за числом 137 8 в восьмеричной системе счисления?...
ccallul
19.06.2019 14:00
Составь кросворд из названий животных и растений тундры...
Популярные вопросы
Фонетический разбор слова мамыр, на казахском языке....
3
Нужен только ответ пример: (3 \frac{2}{3} +1\frac{3}{1}): (6\frac{7}{12}...
3
Во сколько раз произведение чисел 10 и 33 меньше произведения...
3
Есе на тему що робить мене щасливою?...
2
Iii. fill in: legend, feast, discovered, grow, bit, invented,...
3
F(x)=(x-3)*(x+3)+9 x=0.5 производная...
3
Доказать, что при a,b,c,d 0 справедливо нер-во: (a+b+c+d)/4...
3
Раскройте скобки и подобные слагаемые (a-3)*(a-7)-2a*(3a-5)...
3
Придумати речення зі словами: учитися, вчитися, вгору, угору,...
2
8класс какой объем при нормальных условиях занимают: а)3 моль...
2