Дан массив d состоящий из n элементов. Найдите максимальный элемент массива и его порядковый номер.
Напишите программу.

arven88 arven88    1   08.04.2020 13:59    1

Ответы
galaktionov964 galaktionov964  12.10.2020 22:41

d=[]

for i in range(int(input())):

   d.append(int(input()))

print(max(d))

print(d.index(max(d)))

ПОКАЗАТЬ ОТВЕТЫ
denisshirockow denisshirockow  12.10.2020 22:41

В объяснении

Объяснение:

Из задания не совсем ясно, необходимо ли в программе производить ввод массиве, если нет, то решение следующее:

# Максимальный элемент массива

_max = max(d)

# Порядковый номер элемента

_index = d.index(_max)

# Вывод

print(_max, _index)

Если запрещено использовать встроенные функции, то:

# первый элемент - максимальный

_max = d[0]

_index = 0

# Цикл по всем элементам

for i, x in enumerate(d):

   # Если элемент больше максимального

   if x > _max:

       _max = x

       _index = i

# Вывод

print(_max, _index)

Если необходимо произвести и ввод, то в начале задачи надо дописать:

n = input('Введите n: ')

d = []

for x in range(n):

   d.append(input('Введите число: '))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика