tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан массив целых чисел.
Дан массив целых чисел. проверить, есть ли в нем одинаковые элементы на языке си!
fuvgkvu
3 23.08.2019 10:00
10
Ответы
незнаякаилизнайка
05.10.2020 14:24
#include <stdio.h>
int main()
{
int n;
printf("n = ");
scanf("%d", &n);
int a[n], i, j, t;
for (i = 0; i < n; i++) {
printf("a[%d] = ", i);
scanf("%d", &a[i]);
}
for (i = 0; i < n; i++) {
t = a[i];
for (j = 0; j < n; j++) {
if ( (t == a[j]) && (j != i) ) {
printf("%d повторяется\n", t);
}
}
}
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
sir58k
11.05.2020 10:36
1. Выберите 3 вида ссылки:a) переход на новую страницуb) сноскиc) гиперссылкиd) изменение разметки документаe) оглавление...
Дашанеси
11.05.2020 10:37
Какому из операторов в блок-схеме алгоритма соответствует прямоугольник? Варианты ответов k=k+1. for (i=1; i 10; i++). if else. cout sum= cin...
Владивостокер
11.05.2020 10:37
Складіть блок-схему фрагмента алгоритму, у якому в цикл з передумовою вкладено неповне розгалуження...
geometriya3
11.05.2020 10:37
3. Напиши к каждой команде их назначения№ Команды Назначение1 2 3 4 Показать или убрать значение переменной Значение переменных можно менять Установить значение переменной...
abbasovamadina2
11.05.2020 10:38
Схожесть сносок и концевых сносок...
lahtina195454
23.08.2019 12:00
50 ! используйте оператор break или continue. определите, содержит ли данное целое число цифру 0....
gybshova
23.08.2019 12:00
9класс, с спользованием оператора writeln лягушка съедает ежедневно на 20% комаров больше, чем предыдущий день и еще два комара. через сколько дней она съест больше 100...
sarinasergeeva
23.08.2019 12:00
Напишите программу вычисления площади кольца, радиусы вводятся с клавиатуры. используйте функцию вычисления площади круга...
Знание111111
25.08.2019 20:00
Проходим цикл с предусловием. нужно составить в pascal 2 программы. 1) дано натуральное число n. написать программу для вычисления суммы членов последовательности 10,15,...
Syrkova1
25.08.2019 20:00
Для чего добавленному объекту нужно задавать обтекание? перечислите виды обтекания. ♥♥♥...
Популярные вопросы
Для данной составь уравнение, которое является её решением. в трёх...
3
Расставьте необходимые знаки препинания. 1.когда ночная роса горный...
3
Решите уравнение 3^12+3х=3^7х...
2
Найти значение выражения: 4: 4/7 - 2 2/5 * 5/6...
2
Произведение корней 9^х-4*3^х+3=0 х - в произведении выступает как...
1
Из выражения dz−z=-7 вырази z . (вводи сначала числа с соответствующими...
2
Укажите словосочетание с личным местоимением. а) не хочу ничего. в)...
1
Совместная жизнедеятельность, распределение обязанностей для выживания...
1
Укажите слово, которое состоит из приставки ,корня,суффикса и нулевого...
2
укажите число принятых или отданных электронов!...
3
int main()
{
int n;
printf("n = ");
scanf("%d", &n);
int a[n], i, j, t;
for (i = 0; i < n; i++) {
printf("a[%d] = ", i);
scanf("%d", &a[i]);
}
for (i = 0; i < n; i++) {
t = a[i];
for (j = 0; j < n; j++) {
if ( (t == a[j]) && (j != i) ) {
printf("%d повторяется\n", t);
}
}
}
return 0;
}