Дан массив а, состоящий из 6 элементов. вывести элементы массива. изменить порядок следования элементов массива на обратный, вывести инвертированный массив. , , составить программу в ! вот, например, я начала. program z10; var p, i: integer; x: array [1..6] of integer; begin for i: =1 to 6 do begin p: =a[i]; а как дальше поменять местами остальные элементы? ?

57den16 57den16    2   28.05.2019 21:20    1

Ответы
lenok1067 lenok1067  26.06.2020 16:02
1)
просто выводим элементы наооборот
program gt;
var a:array[1..6]of longint;
n,i:integer;
begin
read(n);
for i:=1 to n do
begin
read(a[i]);
end;
for i:=6 downto 1 do
begin
write(a[i],' ');
end;
end.
2)
добавляем дополнительный массив b
program gt;
var a,b:array[1..6]of longint;
n,k,i:integer;
begin
read(n);
k:=7;
for i:=1 to n do
begin
read(a[i]);
k:=k-1;
b[k]:=a[i];
end;
for i:=1 to 6 do
begin
write(b[i],' ');
end;
end.
3)
Изменяем элементы массива без дополнительных элементов
Program z10;
VAR 
p, i: Integer; 
x: Array [1..6] of integer;
Begin
For i:=1 to 3 Do 
begin
p:=a[i];
a[i]:=a[6-i+1];
a[6-i+1]:=p;
end;
for i:=1 to 6 do
begin
write(a[i],' ');
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика