tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан массив а(15). его
Дан массив а(15). его элементы случайным образом от -35 до 50. найти сумму и среднее значение отрицательных эл-тов, сумму и кол-во положительных эл-тов. решить всё в паскале
Артерия
1 31.07.2019 07:40
1
Ответы
ushatkin1
28.09.2020 13:28
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
var a:=ArrRandom(15,-35,50); a.Println;
Writeln('Сумма отр.=',a.Where(x->x<0).Sum,', ср.арифм.отр=',
a.Where(x->x<0).Average:0:5);
Writeln('Сумма пол.=',a.Where(x->x>0).Sum,', кол-во пол.=',
a.Where(x->x<0).Count)
end.
Тестовое решение
13 9 18 -29 -33 7 41 -15 -2 10 7 -32 13 16 -1
Сумма отр.=-112, ср.арифм.отр=-18.66667
Сумма пол.=134, кол-во пол.=6
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
catttttttttttttttttt
07.07.2019 23:20
Вшколе 3 этажа: на первом этаже y кабинетов на 2 и з этаажах по z кабинетов. определить количество кабинетов в школе. y=10 z=14 информатика...
lebedko2004
07.07.2019 23:20
Составить программу паскаль. вывести на экран название операции сравнения, соответствующей введенному с клавиатуры символу: , ,=. ответ записать в виде: была введена операция...
Даун766
09.08.2019 16:40
Заданы площади круга r и квадрата s. определить, поместится ли круг в квадрате. решить при: 1) r=3.2, s=3.5; 2) r=3.2, s=4; 3) r=6, s=9. составить алгоритм решения...
Pancho2234
28.10.2020 11:02
Чем отличается проектирование БД от разработки БД....
1крутой1дядя1
28.10.2020 11:02
Какова цель фишинговой атаки?...
VKaurovau
28.10.2020 11:02
со 2 заданием, сделать системы тестов...
fatyaa22
10.07.2019 07:30
Составить программу, которая создает и выводит на экран массив такого вида: 0 1 1 1 1 1 0 1 0 1 1 1 0 1 1 1 0 1 0 1 1 1 1 1 0 1 1 1 1 1 0 1 0 1 1 1 0 1 1 1 0 1 0 1 1 1...
верника3
17.01.2022 12:11
Программирование 9 класс Массивы Программа через паскаль...
Fkrfi134F
17.01.2022 12:09
Отметьте достоинства структуры «звезда». 1) защита данных лучше, чем для шиннойструктуры; 2) простота и дешевизна;3) небольшой расход кабеля;4) при неисправности любого...
Diron2004
21.02.2021 16:04
Фрагмент молекули полімеру, що повторюється багато разів це А) гомологічна різниця Б) елеметарна ланка В) група атомів CH2Г) радикал CH3...
Популярные вопросы
Соотнеси понятия и их определения. 1) выработанный или установленный...
2
Объясните на основе знаний об электродиссоциации почему растворы кислот...
2
Какая орфограмма в слове вовлечь? пропущен мягкий знак...
3
По окружающему миру надо написать или найти легенду о цветах.кто сталкивался...
2
Решить: по указанному значению одной тригонометрической функции найдите...
2
Найдите сумму критических точек функции y=(x^3)/3+2x^2-5x-7 ! )...
2
Сочинить сложное предложение со словами, последние звёзды тихо погасли....
3
Можно ли назвать сочетания основной и частей в сказуемых - словосочетаниями?...
2
Написать рассказ о тимуровских достижениях из фильма тимур и его команда!...
2
Вычисли периметр прямоугольника, если его площадь равна 140 см2, а...
3
begin
var a:=ArrRandom(15,-35,50); a.Println;
Writeln('Сумма отр.=',a.Where(x->x<0).Sum,', ср.арифм.отр=',
a.Where(x->x<0).Average:0:5);
Writeln('Сумма пол.=',a.Where(x->x>0).Sum,', кол-во пол.=',
a.Where(x->x<0).Count)
end.
Тестовое решение
13 9 18 -29 -33 7 41 -15 -2 10 7 -32 13 16 -1
Сумма отр.=-112, ср.арифм.отр=-18.66667
Сумма пол.=134, кол-во пол.=6