Дан целочисленный прямоугольный массив 6x10. опишите в программе "паскальавс" алгоритм вычисления суммы минимальных элементов из каждой строки. напечатать значение этой суммы. предполагается, что в каждой строке минимальный элемент единственный.

milamilmi milamilmi    3   27.06.2019 20:00    4

Ответы
VarLen20005 VarLen20005  22.07.2020 08:28
Var 
a:array [1..6,1..10] of integer;  b,i,j,k,l: integer;  
begin 
 b:=0; 
 for i:=1 to 6 do 
 begin   
  k:=32000;   
  for j:=1 to 10 do   
  begin     
   read(l);     
   if (l<k) then k:=l;   
  end;   
  b+=k; 
 end; 
 write(b);
end.
Проверено:
1 2 3 4 5 6 7 8 9 10
10 9 8 7 6 5 4 3 2 1
1 2 3 4 5 6 7 8 9 10
10 9 8 7 6 5 4 3 2 1
1 2 3 4 5 6 7 8 9 10
10 9 8 7 6 5 4 3 2 1
ответ - 6
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика