Дан целочисленный массив из 7 элементов, в котором записаны значения температуры воздуха за неделю. Элементы массива могут принимать значения от (–10) до 0. Составьте программу, которая подсчитывает и выводит номер дня недели, когда температура была максимальной.

novkristinaa novkristinaa    1   09.11.2020 18:40    10

Ответы
irinamiller93 irinamiller93  09.12.2020 18:43

var

 temp:array [1..7] of shortint;

 i,max:byte;

begin

 randomize;

 for i:=1 to 7 do temp[i]:=random(10)-10;

 max:=1;

 for i:=2 to 7 do if temp[i]>temp[max] then max:=i;

 writeln(max);

end.  

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика