Подскажите . (для программы кумир и паскаль) написать программу в процессе выполнения которой, получить случайное трехзначное число и вывести через запятую его отдельные цифры. пример: получено число 123. его цифры 1, 2, 3. примечание: используйте функцию irand, операции div и mod.

Гммммм Гммммм    3   16.07.2019 19:00    4

Ответы
Utepovabay Utepovabay  03.10.2020 05:53
Решение на паскале:
//PascalABC.NET
//NaaMan
var
    n,i:integer;
    r,c,s:string;
begin
    randomize;
    n:=random(100,999);
    writeln('Сгенерированное число > ', n);
    s:=','; r:='.'; c:='';
    for i:=1 to 3 do begin
        if (i=3) then s:='';
        str(n mod 10,c);
        r:=concat(s,c,r);
        n:=n div 10;
    end;
    writeln(r)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика