Дан целочисленный массив из 10 элементов все элементы которого целые числа в интервале от - 1000 до 1000. напишите программу которая находит количество элементов всех нечетных элементов массива которые делятся на 3 на языке pascal желательно

Кица234 Кица234    2   14.06.2019 08:40    5

Ответы
Luvizum Luvizum  02.10.2020 01:35
var   a: array [1..30] of integer;
i,k: integer;
begin

k:=0;
все в цикле (примерно так: for i:=1 to 10 do...)(это чтобы прокручивать цикл)
if ((a[i] mod 2=1) and (a[i] mod 3=0)) then k=k+1;
writeln(k);end.
что-то вроде этого,я уже точно не помню язык pascal; 
ПОКАЗАТЬ ОТВЕТЫ
mrvlad12 mrvlad12  02.10.2020 01:35
Program E08;
  uses crt;
    var
      X: array[-1000..1000] of integer;
      S,i,k: integer;
begin
  clrscr;
  writeln('Введите массив X:');
  for i:=1 to 10 do
    begin
      write('X[',i:2,'] ==> ');
      readln(X[i])
    end;
      for i:=1 to 10 do
    write(X[i],' ');
    writeln;

  K:=0;

    for i:=1 to 10 do
    begin
      S:=X[i] mod 3;
      if S = 0 then
        K:=K+1
    end;
      writeln('ответ: ',K)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика