Циклы!

ниже записана программа. получив на вход число x , эта программа печатает два числа, l и m. укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 10.

var x, l, m: integer;

begin

readln(x);

l : = 0;

m : = 0;

while x > 0 do

begin

l : = l + 1;

if m < x then begin

m: =(x mod 10)*2;

end;

x : = x div 10;

writeln(l);

writeln(m);

end.

максимальное число у меня - 959.
но я не уверенна

злючка26 злючка26    1   25.08.2019 00:37    1

Другие вопросы по теме Информатика