tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
C++. составьте программу,
C++. составьте программу, где вводят 4-значное натуральное число и переставляет его первую и последнюю цифру. например, 3456 должно получиться 6453
LIKA03072017
3 23.09.2019 04:40
3
Ответы
ekaterinavarfo
08.10.2020 11:26
#include <iostream>
using namespace std;
int main() {
int n;
cin >> n;
int a = n % 10, b = (n / 10) % 10, c = (n / 100) % 10, d = n / 1000;
cout << a * 1000 + c * 100 + b * 10 + d;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
zhanym2
10.12.2019 14:12
Циклы с неизвестным числом повторений 3,4 вычислить произведение чисел: 2; 2.1 ; 2.2 ; ; 3. (pascal abc)...
nastalut207
10.12.2019 14:10
Заполните следующую таблицу...
bpanraw
10.12.2019 14:10
Создайте программу на python для игры танки в лабиринте 45 если это будет правильно, могу даже прислать деньги!...
pedyxa12
10.12.2019 14:09
C++ пользователь вводит прибыль фирмы за год (12 месяцев). затем пользователь вводит диапазон (например, 3 и 6 - поиск между 3-м и 6-м месяцем). необходимо определить месяц,...
kotenok88
10.12.2019 14:09
Что делать если на модеме не загараются не один из четырёх (lan)...
Noob335
10.12.2019 14:07
Написать программу, которая проверяет, находится ли введенное с клавиатуры число в массиве.массив должен вводиться во время работы программы. (pascal abc)...
unicorn337228
10.12.2019 14:05
Как называются на модеме маленькие комьпьютрики из всего 4 !...
Unicorn7
10.12.2019 14:02
1. описать структуру данных студент с атрибутами: факультет, группа, адрес, год рождения, учебное заведение, рейтинг на курсе. указать операции, определенные для этой структуры....
raiskadem
13.04.2020 19:50
Напишите программу на языке Паскаль, которая вычисляет значение функции y=0, если х меньше или равно 0 y=x, если 0 меньше х меньше или равно 1 y=x², если х больше 1 ХЕЛП...
yarik28032001
13.04.2020 19:50
Какое условие нужно задать для поиска в сети Интернет информации о насекомых, встречающихся как в Австралии, так и в Канаде? насекомые & Австралия & Канада насекомые...
Популярные вопросы
в) 3. Розв яжи задачу. Поїзд, рухаючись рівномірно зі швидкістю 60 км/год,...
2
составить кросворд на тему абсолютная монархия 18 слов каждая буква должна...
3
Краткий сюжет сказки Спящая Царевна Жуковского....
2
Объясните, почему во время войны сфагнум использовали как перевязывающий...
3
. Write the sentences as the III Conditional. 1) She would have been very...
1
Найти на карте климатических поясов в каких климат.поясах находится Зарубежная...
3
Напишите рассказ о том какие есть гаджеты в моем доме, на английском (желательно...
3
по братски. Химия 11 класс...
3
Найдите плотность сплава из 445 г меди и 730 г Олова....
3
Сложение Дробей с разными знаминятелями. заранее)...
2
using namespace std;
int main() {
int n;
cin >> n;
int a = n % 10, b = (n / 10) % 10, c = (n / 100) % 10, d = n / 1000;
cout << a * 1000 + c * 100 + b * 10 + d;
}