Написать программу, которая проверяет, находится ли введенное с клавиатуры число в массиве.

массив должен вводиться во время работы программы. (pascal abc)

Noob335 Noob335    2   10.12.2019 14:07    4

Ответы
oksankavdovina oksankavdovina  10.10.2020 19:45

const n=8;

var a: array[1..n] of integer;

c,i: integer;

f: boolean;

begin

f:=false;

writeln('введите массив из ',n,' элементов:');

for i:=1 to n do readln(a[i]);

write('введите число: ');

read(c);

for i:=1 to n do if a[i]=c then begin

f:=true;

break;

end;

if(f) then write('введенное число находится в массиве')

else write('введенное число не находится в массиве');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика