tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
C++ сформировать одномерный
C++ сформировать одномерный массив из количества положительных элементов матрицы
бакир3
1 09.07.2019 08:40
15
Ответы
dfhjkgftg357
16.09.2020 23:18
#include <iostream>
using namespace std;
int main() {
int mat[3][3];
int k;
int size=0;
int * arr=0;
for(int i=0;i<3;i++){
for(int j=0;j<3;j++){
cin>>mat[i][j];
if (mat[i][j]>0){
arr=(int*)realloc(arr,sizeof(int)*(++size));
arr[size-1]=mat[i][j];
}
}
}
for(int i=0;i<size;i++){
cout<<arr[i];
}
delete arr;
cin.get();
cin.get();
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Natashazzz
29.08.2019 01:50
Напишите программу, которая запрашивает 3 числа и вывожит на периметри треугольника )...
Aaaaaarrrrr55
23.06.2019 03:20
Если кто в 6 классе проходит по информатике тему черепашки , то есть это такая программа , которая рисует фигуры при команд ( к примеру( вп 40 лв 90 вп30).вот по этой теме не могу...
vershynska
23.06.2019 03:20
Какое заключение можно сделать из высказываний все книги имеют страницы , учебник информатики - книга ?...
bratdrug27p09mj2
23.06.2019 03:20
Вкакой форме в основном представляется алгоритм решения на уроках ? а) таблица б) схема в) словесно г) рисунок...
Xylinado
23.06.2019 03:20
4. установите соответствие между названиями информационных процессов и примерами таких процессов. 1. хранение a.улыбка окружающим 2. защита b.взгляд на термометр 3. передача c.паролирование...
ymolyauy
23.06.2019 03:20
Вэт значение формулы=сумм(a1: a4) равно 13, а значение формулы=cp3haч(a1: a5) равно 3. чему ровно значение ячейки a5?...
iamzayka
14.04.2020 17:15
Охарактеризуйте исполнителя чертёжник 6кл с127...
Master2111
14.04.2020 17:14
Выберите строки, в которых условные операторы на языкеPascal записаны без ошибок.if 10 then k:= k+1;if (x mod y=0) then else writeln( no)if x 0 then y:= 100 div x; еlѕе y= 0;if x 0...
AngelChan2004
14.04.2020 17:13
7. Проаналізуйте побудовані діаграми та запишіть у зошит відповіді натакі запитання:а) Скільки рядів даних представлено на кожній діаграмі?б) За значеннями якого діапазону клітинок...
jkh40949
14.04.2020 17:13
Выводит странные числа (язык Паскаль) program JoJo; var d,a,b,c:real; begin writeln ( введите a,b,c ); read (a,b,c); d:=sqr(b)-4*a*c; writeln ( дискриминант= , d); end....
Популярные вопросы
Проверочное слово к словам: земляникой и весну надо проверить е...
3
Счем связано восстание твери в 1327...
3
Утани а конфет. это на б конфет меньше чем у алены. в сколько раз больше конфет...
1
Начертите отрезок длинной 18 клеточек. начертите отрезки, равные одна девятая, четыре...
1
Какая дробь всегда ровняется одному. 11 !...
3
Как сговор печорина с азаматом повлиял на судьбу бэлы?...
3
Вырази в квадратных дециметрах и квадратных метрах. 956 см2; 408 см2; 130 см2; 560...
1
Вычеслите радиус окружности длина которой равна 1) 18,84...
1
Таня выплнила деление 70070: 7 и 840192: 6 столбиком и получила результат 1010и140032...
3
Вчем различия конституционного статуса рф и конституционно-правового статус российского...
3
using namespace std;
int main() {
int mat[3][3];
int k;
int size=0;
int * arr=0;
for(int i=0;i<3;i++){
for(int j=0;j<3;j++){
cin>>mat[i][j];
if (mat[i][j]>0){
arr=(int*)realloc(arr,sizeof(int)*(++size));
arr[size-1]=mat[i][j];
}
}
}
for(int i=0;i<size;i++){
cout<<arr[i];
}
delete arr;
cin.get();
cin.get();
return 0;
}