C++ ПОЛНАЯ ПРОГРАММА НОК
Напишите программу, которая вычисляет наименьшее общее кратное двух чисел.

Входные данные

Входная строка содержит два натуральных числа, разделённые пробелом, — a и b. Гарантируется, что ответ не превосходит 2⋅10^9
Выходные данные

Программа должна вывести одно натуральное число: НОК заданных чисел.

Примеры
Ввод
14 21
Вывод
42

refdiamond refdiamond    2   19.07.2022 15:01    4

Ответы
PavlPavl PavlPavl  19.07.2022 15:02

Объяснение:

#include <iostream>

using namespace std;

long nod (int a, int b)  {

   return b == 0 ? a : nod (b, a % b);

}

int main() {

   int t1, t2;

   cin >> t1 >> t2;

   cout <<  t1 * (t2 / nod (t1, t2));

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика