C++ напишите программу, которая запрашивает пять целых чисел и выводит в первой строке сумму первых двух чисел, во второй строке -- сумму первых трёх чисел, в третьей строке -- сумму первых четырёх чисел, в четвёртой строке -- сумму всех пяти чисел. заранее !

Tuchka2oo5 Tuchka2oo5    2   28.09.2019 17:00    11

Ответы
shargorod81 shargorod81  09.10.2020 00:59

#include <array>

#include <iostream>

#include <algorithm>

#include <numeric>

#include <iterator>

int main()

{

   std::array<int, 5> arr;

   std::generate(arr.begin(), arr.end(), []()

   {

       return 1 + std::rand() % 100;

   });

   std::copy(arr.begin(), arr.end(),

       std::ostream_iterator<int>(std::cout, " "));


   std::cout << std::endl << std::accumulate(arr.begin(), arr.end()-3, 0) << std::endl;

   std::cout << std::accumulate(arr.begin(), arr.end()-2, 0) << std::endl;

   std::cout << std::accumulate(arr.begin(), arr.end()-1, 0) << std::endl;

   std::cout << std::accumulate(arr.begin(), arr.end(), 0) << std::endl;

}


C++ напишите программу, которая запрашивает пять целых чисел и выводит в первой строке сумму первых
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика