C++ напишите программу, которая в последовательности целых чисел определяет разность максимального и минимального чисел. программа получает на входе целее числа, количество введённых чисел неизвестно, последовательность чисел заканчивается число 0 (0 - признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30000. программа должна вывести одно число: разность максимального и минимального чисел.

Esken213141 Esken213141    1   04.07.2019 06:40    4

Ответы
Auebandit1337 Auebandit1337  02.10.2020 19:45
#include <iostream>
#include <vector>
using namespace std;
int main()
{
vector <int> v (1000);
int max = -30000;
int min = 30000;
for (int i = 0; i <1000; ++i) {
cin >> v[i];
if (v[i] == 0) break;
if (v[i] >= max) max = v[i];
if (v[i] <= min) min = v[i];
}
cout << max -min <<endl;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика