C++ code blocks напишите программу, которая в последовательнсти целых чисел определяет количество нечетных чисел, кратных 3. программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введеные числа по модулю не превышают 30 000. программа должна вывести два числа: длину последовательности (завершающий 0 не учитывается) и количество нечетных чисел, кратных 3.c

живууууу живууууу    3   02.10.2019 07:01    4

Ответы
samsonovich12S1 samsonovich12S1  09.10.2020 11:12
#include <iostream>
using namespace std;

int main() {
int k = 0;
int n = 0;
int x;
do {
cin >> x;
if (x != 0) {
++n;
if (x % 2 == 1 && x % 3 == 0) ++k;
}
} while (x != 0);
cout << n << " " << k << endl;
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика