Составить программу на паскале для получения таблицы умножения в шестнадцатеричной системе счисления с использованием типа переменной char, оператора case и функции chr(z1+48) - для получения символьного значения цифры от 0 до 9 (где z1 – переменная для первой цифры произведения)

KULLRUS1 KULLRUS1    1   04.07.2019 17:10    3

Ответы
к1о2л3я4 к1о2л3я4  28.07.2020 10:21
Var
A,B:integer;
C,H:Char;
Begin
For B:= 1 to 15 do
 Begin
 For A:= 1 to 15 do
  Begin
   Case (A*B) mod 16 of
   0:H:='0';
   1..9:H:=Chr(((A*B)mod 16)+48);
   10:H:='A';
   11:H:='B';
   12:H:='C';
   13:H:='D';
   14:H:='E';
   15:H:='F';
   End;
   Case (A*B)div 16 of
   0:C:='0';
   1..9:C:=Chr(((A*B)div 16)+48);
   10:C:='A';
   11:C:='B';
   12:C:='C';
   13:C:='D';
   14:C:='E';
   15:C:='F';
   End;
   Write(C+H,' ')
  End;
 WriteLn
 End
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика