tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Блок-схема и программка на
Блок-схема и программка на с++ получить матрицу а размера , заполненную случайными числами от -7 до 9. получить одномерный массив в, элементы которого являются соответствующими суммами элементов столбцов матрицы а.
Кисуня111111111
3 10.07.2019 09:20
2
Ответы
murad2097
17.09.2020 11:41
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;
int main(){
srand(time(0));
int n,m;
cin>>n;
cin>>m;
int **a=new int *[m];
for(int i=0;i<m;i++)
a[i]=new int[n];
cout<<"Matrix A:";
for(int i=0;i<m;i++){
cout<<"\n";
for(int j=0;j<n;j++){
a[i][j]=rand()%17-7;
cout<<a[i][j]<<" ";
}
}
int *b = new int[m];
cout<<"\n Array B:";
for(int j=0;j<n;j++){
b[j]=0;
for(int i=0;i<m;i++){
b[j]=b[j]+a[i][j];
}cout<<b[j]<<" ";
}
cin.get();
cin.get();
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
adelina121212
04.12.2019 00:46
Небольшое сообщение на тему антивирусные программы 1. создания 2. как они работают 3. их особенности 4. заключение...
EeeeeeeROOOCK
04.12.2019 00:48
Это в excel. можно сразу всё посчитать, чтобы не вводить в каждую ячейку формулу? (решено)...
LiliLaind
04.12.2019 00:57
Как ответить на вопрос ? какие легенды и мифы о лабиринтах ты знаешь?...
kNoPoCHkA96
04.12.2019 01:12
как записать это формулой в excel? ...
LeraLis201
10.03.2021 13:03
Створити проект по інформатиці, в лазарус. Більше з чисел зменшити на 5, а менше збільшити в 3 раза...
irinalera22
10.03.2021 13:03
Программирование арифметических операций на языке Ассемблер Составить программу на языке ассемблер для микропроцессора Intel 8080, вычисляющую значение функции Y. Соблюдение...
kozlovvlad21
02.12.2020 19:13
Отрицанием высказывания «Некоторые школьникипредпочитают изучать испанскийязык»является высказывание:«Неверно, что некоторыеО школьники предпочитаютизучать не испанский...
popdaniela820
02.12.2020 19:13
VBA. Дано натуральное число n. Получить все натуральные числа, меньшие n и взаимно простые (целые числа называются взаимно простыми,если они не имеют никаких общих делителей,...
VaBaGaBa
02.12.2020 19:14
Дана таблица. Необходимо заполнить таблицу. Выбери правильный ответ. Диск Общая информация Ёмкость На диск можно записывать файлы несколько раз (каждая запись называется...
Romakot
02.12.2020 19:14
ДО ТЬ 1 КЛАС ЛЕГКОТЬНЯ ТІЛЬКИ НЕЗНАЮ ЯК ПРАВЕЛЬНО Чим формула відрізняється від інших даних ЕТ? якщо не по темі то бали заберу і бан...
Популярные вопросы
Тема: країни та торгові марки, що застосовують ГМО. можно просто хотя...
2
В производстве телевизоров внедрена новая технология, которая должна...
3
у меня осталось 10 минут....
2
со фторым заданием побыстрее...
3
ТЕКСТ ЗАДАНИЯ Выпиши словосочетание с именем прилагательным в форме родительного...
2
Определить требуемый объем видеопамяти в байтах компьютера, который необходим...
2
10) Укажите равные треугольники. Найти: угол BCD. 12) Укажите равные...
2
чому на вашу думку перший історичний роман в Українські літературі був...
2
Колонка А 54 Высота Эйфелевой башни в Париже 300 м. Чему будет равна...
2
Составьте рассказ по плану...
2
#include <ctime>
#include <cstdlib>
using namespace std;
int main(){
srand(time(0));
int n,m;
cin>>n;
cin>>m;
int **a=new int *[m];
for(int i=0;i<m;i++)
a[i]=new int[n];
cout<<"Matrix A:";
for(int i=0;i<m;i++){
cout<<"\n";
for(int j=0;j<n;j++){
a[i][j]=rand()%17-7;
cout<<a[i][j]<<" ";
}
}
int *b = new int[m];
cout<<"\n Array B:";
for(int j=0;j<n;j++){
b[j]=0;
for(int i=0;i<m;i++){
b[j]=b[j]+a[i][j];
}cout<<b[j]<<" ";
}
cin.get();
cin.get();
return 0;
}