Без повторений
С заданного массива целых чисел нужно удалить все дублирования элементов. То есть из нескольких одинаковых элементов в массиве остается только элемент с наименьшим индексом.

Входные данные
В первой строке записано число N. В следующей строке записано N целых чисел. Все числа по модулю не превышают 100.

Выходные данные
Вывести элементы массива без повторений в одной строке через пробел, не меняя первоначальный порядок.

Входные данные #1
7
0 1 -2 1 0 0 3
Выходные данные #1
0 1 -2 3
На С++

lyba228337ggg lyba228337ggg    2   26.04.2020 23:19    7

Ответы
koookBook koookBook  13.10.2020 22:10

#include <iostream>

using namespace std;

int main()

{

int i,j,N;

cin >> N;

int* A = new int[N];

for (i = 0; i < N; i++) cin >> A[i];

for (i = 0; i < N; i++)

{

 for (j = 0; j < i; j++)

  if (A[i] == A[j]) break;

 if (i==j) cout << A[i] << " ";

}

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика