А)составить программу, которая увеличивает в 10 раз все элементы массива. б) заменяет все отрицательные элементы их индексами. сделать нужно и а и б. через паскаль надо.

bulatnurtdinov bulatnurtdinov    3   10.08.2019 18:40    3

Ответы
nik180208mailru nik180208mailru  04.10.2020 09:51
//PascalABC.NET 3.2 сборка 1318

//а

begin
  writeln('Введите размерность:');
  var n:=ReadInteger();
  writeln('Введите массив:');
  var ar:=ReadArrInteger(n);
  ar.Transform(x -> x*10);
  ar.Print;
end.

//б

begin
  writeln('Введите размерность');
  var n:=ReadInteger();
  writeln('Введите массив:');
  var ar:=ReadArrInteger(n);
  for var i:=0 to n-1 do            //индексация с 0
    if ar[i]<0 then ar[i]:=i;
  ar.Print;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика