9класс информатика дан целочисленным массив из 20 элементов, все элементы которого положительные числа , не превосходящие 100. напишите программу которая находит и выводит номер элемента , имеющего максимальное количество целочисленных делителей ( если таких элементов несколько, то номер любого из них). на паскале абс заранее

milana6164 milana6164    1   23.09.2019 03:01    1

Ответы
avdzhrr avdzhrr  08.10.2020 11:19
Const n=20;
var a: Array [1..n] of integer;
i,j,m,d,dm: Integer;
begin
for i:=1 to n do
a[i]:=random(100);
writeln (a);
for i:=1 to n do
begin
d:=0;
for j:=1 to a[i] do
if a[i] mod j = 0 then d:=d+1;
if d>dm then
begin
dm:=d;
m:=i
end
end;
writeln (m)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика