8 класс. Питон. Задача1. Строковый метод isdigit() проверяет, состоит ли строка только из цифр. Напишите программу, которая запрашивает ввод двух целых чисел и выводит их сумму. В случае некорректного ввода программа не должна завершаться с ошибкой, а должна продолжать запрашивать числа.

Задача 2. Напишите шаблон по запросу у пользователя логина и пароля. Если логин или пароль будут введены с ошибкой, то необходимо вывести сообщение о том, что такой логин или пароль не найдены. Если логин и пароль совпадают, то вывести приветствие с указанием имени пользователя.

NormerSE NormerSE    3   04.03.2021 15:42    34

Ответы
kupmvik kupmvik  03.04.2021 15:43
1)

x,y = map(str,input().split())

while not (x.isdigit() and y.isdigit()):

   x,y = map(str,input().split())

print(int(x)+int(y))

2)

Correct_login = "maxum000"

Correct_passw = "12345"

while (True):

   login = input("Логин: ")

   passw = input("Пароль: ")

   if (login == Correct_login and passw == Correct_passw):

       print("Добро ,", login)

       break

   elif (login != Correct_login):

       print("Такого пользователя и пароля не существует.")

   elif (login == Correct_login and passw != Correct_passw):

       print("Неверный пароль, попробуйте снова.")

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика