70 ! надо написать программу на языке паскаль, которая вычисляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел. всё это надо написать одной программой через оператора repeat. не с !

пОмО0гите пОмО0гите    3   27.05.2019 21:47    46

Ответы
FireLily FireLily  01.10.2020 13:03

program raf105;

var

 n,i,a,b,c,d,sqrt: integer;

begin

 write('Введите n: ');

 readln(n);

 repeat

   i:= i+1;

   a:= a+i;

   sqrt:= i*i;

   b:= b+sqrt;

   if i mod 2 = 0

     then c:= c+i;

   if (i >= 10) and (i <= 99)

     then d:= d+i;

 until i = n;

 writeln('а) ',a);

 writeln('б) ',b);

 writeln('в) ',c);

 writeln('г) ',d);

end.

PascalABC 3.4.2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика