7.написать программу на паскале вычисления значения функции (х^2 при х> 0 х-12 при х≤0) 8.написать программу на паскале нахождения периметра произвольного четырехугольника, данные вводить с клавиатуры. 9.написать программу на паскале вычисления значения выражения у=15х3+3х2-6 10.написать программу на паскале вычисления значения функции (х^2+5х-4 при х> 3 х при х≤3)

yulia6263 yulia6263    3   03.09.2019 03:00    4

Ответы
Лях1 Лях1  06.10.2020 13:50
//7.Написать программу на Паскале вычисления значения функции(х^2 при х>0 х-12 при х≤0)

var
x:integer;
begin
writeln('Введите x');
readln(x);
if x>0 then writeln('ответ ', power(x,2))
else writeln('ответ ', x-12);
end.

//8.Написать программу на Паскале нахождения периметра произвольного четырехугольника, данные вводить с клавиатуры.

var
a,b,c,d:integer;
begin
writeln('Введите a,b,c,d');
readln(a,b,c,d);
writeln('P= ', a+b+c+d);
end.

//9.Написать программу на Паскале вычисления значения выражения у=15х3+3х2-6

var
x:integer;
begin
writeln('Введите x');
readln(x);
writeln('ответ ', 15*power(x,3)+3*power(x,2)-6)
end.

//10.Написать программу на Паскале вычисления значения функции(х^2+5х-4 при х>3х при х≤3)

var
x:integer;
begin
writeln('Введите x');
readln(x);
if x>3 then writeln('ответ ', power(x,2)+5*x-4)
else writeln('ответ ', x);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика