tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
7. дан массив а из 20 элементов.
7. дан массив а из 20 элементов. заменить отрицательные эле-менты массива на среднее арифметическое элементов массива. результат вывести на печать.
00KARTOSHKA00
2 27.06.2019 12:40
3
Ответы
nikitacRon
21.07.2020 22:44
Var Sr:real;
i,n:integer;A:Array[1..20] of real;
beginfor i:=1 to 20 do begin
A[i]:= random(100)-50;
write(A[i]:5);
Sr:= Sr + A[i];
end;
Sr:= Sr/20;
Writeln(' Sr= ', Sr);
for i:=1 to 20 do begin
if A[i] < 0 then A[i]:= Sr;
write(A[i]:5);
end;end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
vdv2001891
23.05.2019 05:30
Расставьте профессии по мере убывания степени использования компьютеров: водитель,программист,актер,бухгалтер,журналист,писатель,повар,швея,учитель,директор,министр...
lolkek6969
03.06.2020 14:34
Html формы парметры поомгите...
vladsmolin4554
03.06.2020 14:44
Какие элементы этого массива по-прежнему будут равны 0? ответ запиши числом.А) 10 Б) 70 В) 79 Г Какие элементы этого массива по-прежнему будут равны 0? ответ запиши числом.А)...
Помогите111234
27.04.2021 20:11
До іть! написати що робить кожен рядок і розв язати задачу ...
Златаник2017
27.04.2021 20:12
Составить программу для исполнителя Чертёжник рисования слова УРОК...
nastya190420
19.09.2019 22:10
Файл размером 16384 бит передается через некоторое соединение со скоростью 0,5 килобайта в секунду. определите размер файла (в байтах), который можно передать за то же время...
егормай
19.09.2019 22:10
Число 23(х) из системы счисления с основанием х перевели в десятичную систему счисления и получили 19(х). найти основание системы счисления х....
petroura2
19.09.2019 22:10
Даны целые трехзначные числа а и b: по заданному алгаритму составьте код программы: алг. сумма нач ввод(а,b) x=a+b вывод (x) кон алг ? код программы 2)входные данные а=345, b=124,6...
ramoxa
19.09.2019 22:10
Число 135(х) из системы счисления с основанием х перевели в десятичную систему счисления и получили 59(10). найти основанием системы счисления х....
veta991
03.12.2020 13:58
В 3D графике мы имеем три измерения Назовите их...
Популярные вопросы
На зиму многие ягоды можно заморозить в магазине также продается мороженое...
2
Икогда все было готово, когда родная планета приняла сравнительно благоустроенный...
2
Danotenience2 c 6 h 2 o 6 we mm 100%2 h₂ 304 mr ic ho) =v.kanca...
1
What reasons can influence your decision on the choise of profession?...
2
Складіть речення з парою слів барва - фарба...
3
Существуют ли натуральные числа m,n,k при которых выполняется равенство1/m+1/n+1/k=1/m+n+k...
3
Перепишите текст, раскрывая скобки, вставляя, где это необходимо, пропущенные...
2
Решите неравенство: а) 3х2-2х-5 0; б) х2 + 6х+ 9 0; в) –х2 + 6х ≥ 0. 2. решите...
1
Сообщение про алексея толстого краткое...
2
Переведите диалог с на : -wer ist das da? -wo? -da links-das bin ich-und wer...
3
i,n:integer;A:Array[1..20] of real;
beginfor i:=1 to 20 do begin
A[i]:= random(100)-50;
write(A[i]:5);
Sr:= Sr + A[i];
end;
Sr:= Sr/20;
Writeln(' Sr= ', Sr);
for i:=1 to 20 do begin
if A[i] < 0 then A[i]:= Sr;
write(A[i]:5);
end;end.