50 с решением информатики 1. написать программу которая считает сумму 2ух введённых чисел и выводит результат на экран; 2. дана следующая функция, написать программу которая находит значение функции по переданному х. использовать оператор ветвления if, then, else. результат вывести на экран: дана следующая функция: y = f (x): y = x - 6, если х > 0 y = 32x - 7, если x = 0 y = 5 x - 2, если х < 0 3. написать программу которая инициализирует массив с 50 значениями, начиная с 1 и поэлементно заполняет его. результат вывести на экран. использовать при написании цикл с параметром.

lilia822 lilia822    3   03.10.2019 17:40    2

Ответы
bryuho20011 bryuho20011  09.10.2020 14:59

1)

var a,b:longint;

begin

readln(a,b);

writeln(a+b);

end.

2)

var x:longint;

begin

readln(x);

if(x>0) then writeln(x-6) else if(x=0) then writeln(32*x-7) else if(x<0) then writeln(5*x-2);

end.

3) В третьей условие не совсем понял, если что, дополни, отредактирую код. Какие значения принимают элементы (по какому принципу заполняется массив)? Написал для массива с элементами от 1 до 50.

var a:array[1..50] of integer;

var i:integer;

begin

for i:=1 to 50 do a[i]:=i;

for i:=1 to 50 do writeln(a[i]);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика