5. Исправьте ошибки во фрагменте программы (напишите верный код) и определите, сколько раз выполняются команды цикла и что вычисляется:
for i:=7 to 25 do;
read (a[i])
if a[i] mod 2 <> 0 then begin p:=p*a[i]; k:=k+1;
​

alyabevan02001 alyabevan02001    1   07.04.2020 00:42    7

Ответы
242Bob 242Bob  06.08.2020 17:59

В данном фрагменте программы идёт

1) if (a[i] mod 2 <> 0) - условие: "если элемент массива нечетный, т.е. при делении на 2 есть остаток, то"

2) p:=p*a[i]; -  операция умножения элементов массива. Произведение обозначено p.

3) k:=k+1; - это суммирование, сколько раз выполняется команда

Верно: for i:=7 to 25 do begin

if (a[i] mod 2 <> 0) then begin p := p*a[i]; k:=k+1; end; end;

Объяснение: все ошибки выделены жирным шрифтом.

for i:=7 to 25 do;

read (a[i])

if (a[i] mod 2 <> 0) then begin p:=p*a[i]; k:=k+1; end;

Если в программе поставить знак ; сразу после запроса действия do (сразу после открытие цикла), она не начнёт выполнение условия. Лишним также является read (a[i]), т.к. программе вновь не задаётся цикл, либо её чтение было уже задано до данного цикла с условием.

Если интересна программа полностью, то вот код ниже, а также скриншот с результатами. Заполнение массива задано автоматически числами от 1 до 100. Размерность массива - 25 чисел. При произведении мы всегда задаём значение переменной 1, иначе программа не начнёт операцию, при сложении присваивать значение только 0, но это необязательно.

Program zadacha;

var  

 a: array [1..25] of integer;

 i,p,k: integer;

begin

  for i:=1 to 25 do

  a[i]:= Random(100); // числа от 1 до 100 будут присутствовать в массиве

writeln('Заполненный массив:'); for i := 1 to 25 do write(a[i],' ');

p:=1; k:=0;

for i:=7 to 25 do begin

if (a[i] mod 2 <> 0) then begin p := p*a[i]; k:=k+1; end; end;;

writeln;

writeln('Произведение нечетных элементов:', p);

writeln('Сколько раз выполнилось условие:', k);

end.


5. Исправьте ошибки во фрагменте программы (напишите верный код) и определите, сколько раз выполняют
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика