350 ! пр информатике. на pascal abc. надо написать программу где нужно ввести 5 цифр в столбик. дальше вывести их на экран. и в конце нужно самое большое число и самое маленькое и поменять их местами.
например:
я ввожу
6
7
8
9
10
максимум-10
минимум-6
10
7
8
9
6
напишите с объяснением

missm0541 missm0541    2   07.08.2019 18:15    1

Ответы
Нига2ц8 Нига2ц8  07.08.2019 20:10

var max,min,a: integer;

mas: array[1..5] of integer;

begin

for a: =1 to 5 do

begin

readln(mas[a]);

if mas[a]< =mas[min] then min: =a ;

if mas[a]> =mas[max] then max: =a ;

end;

writeln;

writeln (mas[max]);

for a: =1 to 5 do

if (a< > min)and(a< > max) then writeln (mas[a]);

writeln(mas[min]);

end.

ПОКАЗАТЬ ОТВЕТЫ
Luuna0111 Luuna0111  07.08.2019 20:10

ответ:

var max,min,a: integer;

mas: array[1..5] of integer;

begin

for a: =1 to 5 do

begin

readln(mas[a]);

if mas[a]< =mas[min] then min: =a ;

if mas[a]> =mas[max] then max: =a ;

end;

writeln;

writeln (mas[max]);

for a: =1 to 5 do

if (a< > min)and(a< > max) then writeln (mas[a]);

writeln(mas[min]);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика